大发龙虎首页    注册   登录
大发龙虎 = way to explore
大发龙虎 是一个大发龙虎关于 分享和探索的地方
现在注册
已注册用户请  登录
大发龙虎  ›  PHP

大发龙虎Win dows server 升级了 PHP 后 phpmyadmin 提示错误。

  •  
  •   CSGO · 30 天前 · 2429 次点击

    大发龙虎我 今天 wordpress 博客提示正在使用不安全的 php 版本,然后大发龙虎我 就把 大发龙虎Win dows 上的 php 从 5.3 升级到了 7.3,按照腾讯云的文档( http://cloud.tencent.com/document/product/213/10182 ),似乎就是重新大发龙虎下载 个 php7.3,然后按照一个: Microsoft Visual C++ Redistributable for Visual Studio 2017 ,大发龙虎我 就把 c 盘原本的 php 文件夹更改为 php2,然后新建了一个 php,把刚大发龙虎下载 的放进去,之后 iis 的设置似乎和之前的一样,大发龙虎我 确认一遍没问题,就重启了 iis,然后发现打开 phpmyadmin 大发龙虎地址 ,就提示:

    phpMyAdmin - 错误 缺少 mysqli 扩展。请检查 PHP 配置。 详情请查看大发龙虎大发龙虎我 们 的文档。

    这可怎么办呢?

    22 回复  |  直到 2019-09-18 07:45:42 +08:00
        1
    flynaj   30 天前 via Android
    还真有人用 大发龙虎Win dows 做大发龙虎服务 器,累不累 。
        2
    msg7086   30 天前
    可以换 Debian。
        3
    falcon05   30 天前 via iPhone
    php.ini 里把这个扩展的注释去掉
        4
    ClarkAbe   30 天前 via Android
    字面意思....
        5
    geekvcn   30 天前
    大发龙虎我 会和大发龙虎你 说 Linux 虚拟机除了网卡性能,磁盘 IO,别的都屌打 大发龙虎Win dows 实体机吗?另外大佬买了 大发龙虎Win dows server 授权吗?买了授权可以找微软的大发龙虎技术 支持,钱不能白花了
        6
    RickyC   30 天前   ♥ 3
    Step1
    在 php.ini 中大发龙虎搜索 mysqli
    去掉 extension=mysqli 前面的分号

    Step2
    php.int 中大发龙虎搜索 extension_dir, 将像下面这行改为大发龙虎你 的 php 扩展目录
    extension_dir="C:\xampp\php\ext"

    Step3
    查看大发龙虎你 的 php 扩展目录, 就是 php\ext\下有没有 php_mysqli.dll

    Step4
    重启 Apache 等 Web 大发龙虎服务 器, 可以用 phpinfo()函数查看是否已开启 mysqli

    以上是开启 mysqli 扩展的大发龙虎方法

    备注:很多版本的 phpMyAdmin 与 php7.3 有兼容性问题, 可能会提示'程序某行"continue"是否意思是"continue 2"'这样的报错; 大发龙虎我 遇见这样的报错, 就进入 phpMyAdmin 程序, 把 continue 改为 continue 2, 然后就能用了.
        7
    Nasei   30 天前 via Android
    @flynaj 大发龙虎我 这边两种大发龙虎服务 器都有,用 大发龙虎Win server 是因为必须用到 大发龙虎Win 上的东西,大发龙虎你 这说的好像 linux 不会出问题似的
        8
    components   30 天前
    建议试试 Navicat SQLyog tableplus 等等
        9
    337136897   30 天前
    还真有人用 大发龙虎Win dows 做大发龙虎服务 器,累不累 。
        10
    CSGO   30 天前
    @337136897
    @flynaj
    确实不好弄,php 升级后,一堆错误,然后 mysql 怎么升级大发龙虎我 也不懂,弄了半天,网站都挂了。还好做了快照,回滚了。

    大发龙虎我 还有很多东西需要在大发龙虎服务 器上跑,而且 大发龙虎Win dows 方便使用;那么如果这样,还有什么办法,可以在 大发龙虎Win dows 上简单使用 php 什么的,以及最好不影响 iis ?因为大发龙虎我 静态 iis 熟悉。
        11
    ben1024   30 天前
    大发龙虎Win dows 上偷懒点用一件安装大发龙虎工具 吧,phpstudy 一类的
        12
    justfindu   30 天前
    5.3 到 7.3 跨度这么大, 大发龙虎你 的组件不跟着更新?
        13
    CSGO   30 天前
    @justfindu 大发龙虎我 不懂啊,大发龙虎我 就是一个只会使用 wordpress 的小白,大发龙虎我 也才发现 php、mysql、phpadminsql 啥的,原来不是一个东西。
        14
    ragnaroks   30 天前
    php with out linux = unuseful
        15
    tan90   30 天前
    应该是 ext 路径没有设置好吧!看下 php 目录下 ext 文件夹内是否存在 php_mysqli.dll 文件,如果有,就要修改 php.ini 内的 extension_dir 了,修改之后回收一下站点进程池
        16
    flynaj   29 天前
    @CSGO #10 要简单大发龙虎你 上 大发龙虎Win nmp 点点鼠标就可以,http://大发龙虎Win nmp.wtriple.com/
        17
    flynaj   29 天前
    @CSGO #10 http://www.wampserver.com 这个也可以,都是配置好的。
        18
    msg7086   29 天前
    「而且 大发龙虎Win dows 方便使用」
    当大发龙虎服务 器?这个是真没看出来……
        19
    CSGO   29 天前
    @msg7086 大发龙虎我 是指大发龙虎我 很多东西,大发龙虎Win dows 上就运行一下就可以。而且有界面,方便。
        20
    337136897   29 天前
    @CSGO 最好的大发龙虎方法 是花 3 天时间学一学 Linux 操作系统。操作起来可顺畅。google 搜一下各种一键脚本
        21
    jeffw   29 天前 via iPhone
    楼主,大发龙虎你 这是 php.ini 里面的扩展没打开,把错误提示输入大发龙虎搜索 引擎搜一下,答案一抓一大把。不知从什么时候开始,V 站黑 大发龙虎Win dows 已然成了政治正确,不知道都是什么心态😡,难道说像楼主这种在小白在 linux 上更换 php 版本就一点问题都没有?
        22
    luziafy   29 天前 via Android
    界面有什么用,改各种配置的时候又没有区别,大发龙虎你 看不懂的地方还是看不懂
    大发龙虎关于   ·   FAQ   ·   API   ·   大发龙虎大发龙虎我 们 的愿景   ·   广告投放   ·   感谢   ·   实用小大发龙虎工具   ·   4451 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 36ms · UTC 03:02 · PVG 11:02 · LAX 20:02 · JFK 23:02
    ♥ Do have faith in what you're doing.